Mini Cooper Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
Hi,

When my wife first took delivery of her Mini back in March, we chose a simple bluetooth setup for her iPhone 11 Pro.

I’ve just tried to setup CarPlay and the option to do so isn’t appearing. I’ve deleted the phone from the car with no success.

The arrowed option below is missing:

69179


Briefly, under settings, bluetooth, a check box for CarPlay briefly appeared, and it was unchecked. I ticked it, but then it said that it couldn’t connect via CarPlay and now the option is missing:

69180



Can anyone help?

Cheers.
 

·
Registered
Joined
·
66 Posts
Hi Sir

Yes, you can lock your car and wait 3 ~ 5 minutes. and try to use it.

Please delete old Bluetooth pairs on your car and phone.
 

·
Registered
2020 Mini Cooper S Sport Auto
Joined
·
100 Posts
Hi, please let me know if this fix works.
I took delivery of a 2020 Mini mid March and connected my iPhone XS with CarPlay with ease.

At some point since then, the CarPlay option has disappeared. I can still play my music through Bluetooth but can’t see the CarPlay screen, use Waze for maps etc. I have tried restarting my iPhone, disconnecting / deleting the connections from my car and my phone, had the engine running etc with no luck.
I had an iPhone software update recently which I fear may have messed with it.
 

·
Registered
2020 Mini Cooper S Sport Auto
Joined
·
100 Posts
Hi all
I managed to find a fix. Go to:
  • Settings
  • Mobile devices
  • Settings
  • There should be 2 options: Bluetooth and Apple carplay - make sure both are ticked.
  • Disconnect both on the car and on the phone
  • Reconnect using the apple CarPlay in iPhone (iPhone settings - general - CarPlay)
This is where I had issues because on my car display it said my iPhone was not compatible and to proceed connecting by Bluetooth. Carry on and connect as Bluetooth only.
Then go back to mobile devices and select your device. There should now be 4 options for connection: telephone, apps, music and apple CarPlay.
Make sure CarPlay is selected.

It took me a few tries and searching through menus but I managed to get there.
Hope this works for you!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
Finally found out what the problem was, but had to wait till the dealer opened again after lockdown was eased.

It hadn’t been enabled at delivery. It appears that the dealer had to reinstall software.
 

·
Registered
Joined
·
3 Posts
I found a solution if your CarPlay was working and suddenly disappeared. While sitting in the car with my iPhone connected via Bluetooth, I force reset my iPhone. When I came back to the CarPlay setting under General, my car appeared! I had to have the phone forget the vehicle under the bluetooth setting, then go back to CarPlay and select it. I may have also had to select CarPlay on my car's screen, but the CarPlay menu option came back then, too! The key is to force reset your phone while on bluetooth with your car. Go from there.
 

·
Registered
Joined
·
1 Posts
Thank You!!!! Tried just about everything and finally came across your solution, worked like a charm!

I found a solution if your CarPlay was working and suddenly disappeared. While sitting in the car with my iPhone connected via Bluetooth, I force reset my iPhone. When I came back to the CarPlay setting under General, my car appeared! I had to have the phone forget the vehicle under the bluetooth setting, then go back to CarPlay and select it. I may have also had to select CarPlay on my car's screen, but the CarPlay menu option came back then, too! The key is to force reset your phone while on bluetooth with your car. Go from there.
 

·
Registered
Joined
·
3 Posts
I found a solution if your CarPlay was working and suddenly disappeared. While sitting in the car with my iPhone connected via Bluetooth, I force reset my iPhone. When I came back to the CarPlay setting under General, my car appeared! I had to have the phone forget the vehicle under the bluetooth setting, then go back to CarPlay and select it. I may have also had to select CarPlay on my car's screen, but the CarPlay menu option came back then, too! The key is to force reset your phone while on bluetooth with your car. Go from there.
Didn’t work for me. I did a phone hard reset and it automatically reconnected back to the Bluetooth, but no CarPlay showed up. Are you restarting the car at all or just the phone?
 

·
Registered
Joined
·
3 Posts
Didn’t work for me. I did a phone hard reset and it automatically reconnected back to the Bluetooth, but no CarPlay showed up. Are you restarting the car at all or just the phone?
It will reconnect, but look in your phone's setting under CarPlay. It should show the car again. Then, go to Bluetooth settings, forget your car, come back to CarPlay and the car should still be a choice. Also, CarPlay should show up on your MINI's screen again as an option for your phone. I didn't restart my car.
 

·
Registered
Joined
·
3 Posts
It will reconnect, but look in your phone's setting under CarPlay. It should show the car again. Then, go to Bluetooth settings, forget your car, come back to CarPlay and the car should still be a choice. Also, CarPlay should show up on your MINI's screen again as an option for your phone. I didn't restart my car.
It’s back. Didn’t work after I tried this last night, but when I checked today it was back. Not sure what happened, but thanks for the help.
 

·
Registered
Joined
·
4 Posts
It’s back. Didn’t work after I tried this last night, but when I checked today it was back. Not sure what happened, but thanks for the help.
Hi guys, same issue here. CarPlay disappeared and its very annoying especially when u use it every day.
I tried the fix that was suggested above but does not work. I followed the steps clearly.
What type of reset of your phone are you doing? Reset network settings or reset all settings?
Nothing appears in general/carplay on my phone...
Any help please?

thx a lot!
 

·
Registered
Joined
·
3 Posts
Hi guys, same issue here. CarPlay disappeared and its very annoying especially when u use it every day.
I tried the fix that was suggested above but does not work. I followed the steps clearly.
What type of reset of your phone are you doing? Reset network settings or reset all settings?
Nothing appears in general/carplay on my phone...
Any help please?

thx a lot!
I did the last posted fix last night and it didn’t work immediately. I turned my car on today to look and it was back. Hard reset your phone while connected to the car’s Bluetooth, and let your car sit for a while. Maybe it had something to do with the car’s system rebooting after resting for a bit.
 

·
Registered
Joined
·
4 Posts
Thanks a lot. I did this as well. Will go check tomorrow then. You may be right with the car's system rebooting itself which might take some time. But by hard reset you mean 'Reset All Settings' on your iphone? I did 'Reset Network settings' cause the issue is connectivity through wifi/bluetooth.
 

·
Registered
Joined
·
4 Posts
I did the last posted fix last night and it didn’t work immediately. I turned my car on today to look and it was back. Hard reset your phone while connected to the car’s Bluetooth, and let your car sit for a while. Maybe it had something to do with the car’s system rebooting after resting for a bit.
Hi again, i went to my mini tonight and still same issue. Carplay does not appear. Out of options, I called Concierge from Mini Assist from the car itself, and the Mini agent told me it is an issue on their side and they are working on it. I was relieved. Apparently, they are going to email everyone impacted by this issue and can even compensate somehow for the issue that was caused. Im gonna wait for them to fix it then. Thx again.
 

·
Registered
Joined
·
9 Posts
Hi again, i went to my mini tonight and still same issue. Carplay does not appear. Out of options, I called Concierge from Mini Assist from the car itself, and the Mini agent told me it is an issue on their side and they are working on it. I was relieved. Apparently, they are going to email everyone impacted by this issue and can even compensate somehow for the issue that was caused. Im gonna wait for them to fix it then. Thx again.
Try this... worked for me. Just got back from my dealer where they showed me this.

1. Remove your phone from the HU
2. Remove your Mini from your phone
3. Go to the main menu on the HU
4. Select Mini Connected
5. Press the OPTION button (physical controls near shifter)
6. Select Update Mini Services and don't click anything until it says it's done.
7. Turn off the car and walk away for at least 10 min
8. Turn the car back on and reconnect your phone. CarPlay should show as an option again.
 

·
Registered
Joined
·
4 Posts
Try this... worked for me. Just got back from my dealer where they showed me this.

1. Remove your phone from the HU
2. Remove your Mini from your phone
3. Go to the main menu on the HU
4. Select Mini Connected
5. Press the OPTION button (physical controls near shifter)
6. Select Update Mini Services and don't click anything until it says it's done.
7. Turn off the car and walk away for at least 10 min
8. Turn the car back on and reconnect your phone. CarPlay should show as an option again.
Thanks a lot. Your solution worked for me. Big relief to see CarPlay back and being able to use it again. Thanks again.
 
1 - 20 of 23 Posts
Top