Mini Cooper Forum banner
21 - 26 of 26 Posts

·
Super Moderator
Joined
·
8,750 Posts
Yes very . Honest John always recommends shell due to its quality additive package although it's effect is limited in direct injection engines like ours. I just buy cheapest I'm afraid but occasionally treat the car to shell nitro
 

·
Registered
Joined
·
10 Posts
If the car is running OK, it's likely either a sensor is getting flaky, or, believe it or not, the GAS CAP is loose.

Double check the gas cap and see if that fixes it.
Thanks uke! Had this issue today, and VOILA! It was the gas cap. I put it on differently than I normally do. Check engine light is now off, and the car is running like new again. Much appreciated. :nerd:
 

·
Registered
Joined
·
4,861 Posts
Since all the Petro/Gas here in Phoenix comes from the same Storage Tanks delivered by the same Fuel Haulers just with different Trailers for BP QT Am/Pm etc etc I normally buy my Gas at Am/Pm and Qt. Sure everybody claims they have the best Cocktail but nobody is so sure about that. I have been doing well with the cheaper Brands. LOL when they filled up my Mini at the Dealer it was from the cheap Brand Station.

Yes the old Gas Cap sets off the Engine Light a lot.:eek:

Lucas makes some excellent Fuel/Octane Booster that I used in the past and have been very happy with. Not cheap but very good.

Glad you got it all sorted out.:)
 

·
Registered
Joined
·
83 Posts
Anyway, this does happen to many people, and ever since I refuse to go back to Asda for their fuel - a lot of reports say Tesco is pretty poor too... apparently sainsbury's use BP fuels. So, my gut feeling is that not all fuels of the same marque are the same.
Dont know where you heard that? Sainsburys buy fuel in bulk like everyone else.

They all use the same fuel. Only difference is the additives.
Shell and BP use better, more refined and tested additives.

Supermarkets add little if any.

If you get a bad batch of fuel, its 99% down to the holding tanks at the filling station either not been drained and cleaned or allowing water to seep in.
 

·
Registered
Joined
·
5 Posts
The longer I own his car the more I dislike it. So many problems. Minute after minute.
My engine factors light came on today upon starting. It's not the gas cap as I filled the tank with shell v power here in Canada on Sunday and drove it hard on the hwy with no issues.
I did notice a weird whistling in first gear after coming off the hwy but as soon as I shifted to 2nd and exceeded 3000rpm nothing.
No whistling today.
Oil level and all other system checks come up ok according to the computer.
Thinking maybe it's a turbo issue.
Oil is new and filter too.
Anyone have issues with turbo around the 100000 km mark? (60000 miles)
Any thoughts or shared experiences very welcomed.
TIA
 
21 - 26 of 26 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top