Mini Cooper Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Hi,
I recently had to replace the battery of my 2019 F56. Long story short First battery replacement ever, I used a low amp charger to start the car and the battery replacement was all done by Mini.

A couple of weeks later I noticed apple car play will not work.
I get the message " Apple CarPlay could not be activated. ".
Could this be just a coincidence or probably the hardware was damaged when replacing the battery or due to low battery?

Should I have any hope that this can be fixed through software or I need to replace the head unit? this is so sad...

Thanks for any feedback
 

Attachments

· Registered
Joined
·
335 Posts
Hi,
I recently had to replace the battery of my 2019 F56. Long story short First battery replacement ever, I used a low amp charger to start the car and the battery replacement was all done by Mini.

A couple of weeks later I noticed apple car play will not work.
I get the message " Apple CarPlay could not be activated. ".
Could this be just a coincidence or probably the hardware was damaged when replacing the battery or due to low battery?

Should I have any hope that this can be fixed through software or I need to replace the head unit? this is so sad...

Thanks for any feedback
are you sure that wifi exist?
 

· Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
are you sure that wifi exist?
Do you mean the issue can be with wifi and not related to carplay software/hardware? Bluetooth works fine.
I updated connectivity software downloading from mini.com/connectivity using USB option.
After succuessfullyninstaing the update the same error shows.
What do I need to verify/diagnose wifi?
Thanks!
 

· Registered
Joined
·
537 Posts
Hi - did your car come with CarPlay from the factory, or was it added to your car after purchase? Either way, if CarPlay previously worked, your headunit has WiFi.

It would also be good to know if your car has telematics or not. If CarPlay is from the factory and you have telematics, I’d update Mini services on the headunit and see if that helps. I’d also try deleting the phone from the car and the car from the phone, rebooting the phone, and then trying to connect.
 

· Registered
Joined
·
21 Posts
Discussion Starter · #5 ·
Hi - did your car come with CarPlay from the factory, or was it added to your car after purchase? Either way, if CarPlay previously worked, your headunit has WiFi.

It would also be good to know if your car has telematics or not. If CarPlay is from the factory and you have telematics, I’d update Mini services on the headunit and see if that helps. I’d also try deleting the phone from the car and the car from the phone, rebooting the phone, and then trying to connect.
Thanks, Yes the car had CarPlay from factory, it was all working fine until a couple of weeks ago.
I have tried deleting all phones, an I also updated Mini services using the option button.

Nothing has been successfull.
I will soon need new front brake pads still covered under Mini service inclusive, I will ask them to diagnose and quote to fix.
 
1 - 5 of 5 Posts
Top