Mini Cooper Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1,894 Posts
Discussion Starter · #1 ·
I opened the hood of my 2016 mini and the left side trim ring fell off! I checked the one on the right and it was missing several of the cheesy plastic clips that hold it in as well. The car has about 15K miles on it. Has anyone else experienced this issue? I searched the forums and I was unable to locate any threads that discussed this particular issue. It's not a big deal other than I have to drive 100 mile round trip to the dealer to have it reinstalled.
 

·
Registered
Joined
·
768 Posts
Nothing like that with my 2015 with 21,000 miles. That's pretty weird, no idea how that would even happen.
 

·
Registered
Joined
·
1 Posts
Did you contact Mini about this issue? Same thing happened to my 2016. I called Mini and they said it wasn’t a ‘known issue’.
I opened the hood of my 2016 mini and the left side trim ring fell off! I checked the one on the right and it was missing several of the cheesy plastic clips that hold it in as well. The car has about 15K miles on it. Has anyone else experienced this issue? I searched the forums and I was unable to locate any threads that discussed this particular issue. It's not a big deal other than I have to drive 100 mile round trip to the dealer to have it reinstalled.
 

·
Registered
2019 Mini Cooper S, 2-Door Hardtop, Moonwalk Grey Metallic
Joined
·
93 Posts
I would notify the dealership and see if they'll send you a bag of clips. Simple fix, although you should have to do it yourself unless you skip that 100 mile roundtrip to the dealer.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top