Mini Cooper Forum banner
1 - 20 of 30 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
I've just got a new iPhone 6S and can no longer get the mini connected app to pair with the car.
The car pairs fine with my old iPhone 5S and also worked straight away with the dealers iPhone 6.

For reference i go to mini connected on the display in the car, go to connection assistant plug in the phone, it then recognises the phone telling me to open the app on the phone which i do and then from there nothing happens.

I have deleted the app from the phone, restored the phone from the backup of my 5S, updated the software in the car and deleted all personal data from the car.

Im wondering if anyone else has managed to get their iPhone 6s to work with the connected app or if this is just an issue with my phone? Or if they have any more suggestions as to what I could do.
 

·
Registered
Joined
·
763 Posts
Works fine with my 6S. Try Launch the app, plug phone into the USB (or armrest), start the car. Takes a second to communicate but it always does.

If you deleted all personal data from the car you may need to add it all again and make sure the car recognizes your new phone. Also, make sure you have the latest version of Connected from the App store.
 

·
Registered
Joined
·
998 Posts
Have you paired the phone with the car through Bluetooth? Might be worth removing the pairing from your old phone and car as well
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #4 ·
Everything's all updated to the latest version. It's iOS 9.3.1 and mini connected version 3.1.

Everything connects fine via Bluetooth and plays music via usb with the phone recognised, it just wi t initialise the connected app and thus can't use the in car Spotify app.
 

·
Registered
Joined
·
763 Posts
If you're not using the Apple white cable try that. Connectivity issues have been reported with non-Apple cables. I use the arm rest but before I had the adapter I used the Apple cord and didn't have any problems when I switched phones.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #6 ·
I've now tried two genuine Apple lightning cables, one which worked fine with the 5s and the brand new one that came with the 6s but still nothing.
I'm wondering if iOS 9.3.1 has broken the app and thus it will no longer pair new devices but continues to work for devices that were paired before the new iOS update.
 

·
Registered
Joined
·
96 Posts
I've now tried two genuine Apple lightning cables, one which worked fine with the 5s and the brand new one that came with the 6s but still nothing.
I'm wondering if iOS 9.3.1 has broken the app and thus it will no longer pair new devices but continues to work for devices that were paired before the new iOS update.
I have a 6S with 9.3.1 which works fine but I was using it before the upgrade to 9.3.1.

I would try removing all traces of the 5S from mini connected as suggested before, then turn of the Mini for a few minutes

Remove any references to Mini on the phone, reboot it then try again.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #8 ·
So I've reset the car to factory removing all connections etc and also reset the iPhone back to factory but it still doesn't work.
I'm going to try and email the app developers to see if they may be able to help.
 

·
Registered
Joined
·
478 Posts
Have you restarted the iPhone ? I have an iPhone 6s and it works fine, but i occasionally have connection problem which I seem to only be able to resolve with a reboot on the iPhone. It got worse with 9.3 (once a week), but is better again with 9.3.1 (i.e. once a month maybe)
 

·
Registered
Joined
·
998 Posts
Have you restarted the iPhone ? I have an iPhone 6s and it works fine, but i occasionally have connection problem which I seem to only be able to resolve with a reboot on the iPhone. It got worse with 9.3 (once a week), but is better again with 9.3.1 (i.e. once a month maybe)
I've found this as well. The car software is definitely buggy though
 

·
Registered
Joined
·
30 Posts
Have you had any response from the app devs?

I've had the same experience with my new iPhone SE. I was even going to the point of returning the iPhone SE and just continue using my prev device, an iPhone 6. However, after I restored the iPhone 6 from backup (I've already erased it), it too won't work normally on my MINI Connected.

So bummed about this.

So I've reset the car to factory removing all connections etc and also reset the iPhone back to factory but it still doesn't work.
I'm going to try and email the app developers to see if they may be able to help.
 

·
Registered
Joined
·
998 Posts
I wonder if its an idea to disconnect the car battery for a few minutes. Seems like these issues are being caused by residual memory in the system
 

·
Registered
Joined
·
28 Posts
On he latest episode of The Maccast Podcast just before 16 mins in there is a reference to Bluetooth issues with the new iPhone SE and cars. Doesn't sound exactly like your issue but there is reference to a discussion about this on the Apple Support forums. Might be worth having a look on their forums. I have a 6s+ and have no Bluetooth issues but it was paired with an iOS version 9.2 I think.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #14 ·
Have you had any response from the app devs?

I've had the same experience with my new iPhone SE. I was even going to the point of returning the iPhone SE and just continue using my prev device, an iPhone 6. However, after I restored the iPhone 6 from backup (I've already erased it), it too won't work normally on my MINI Connected.

So bummed about this.
I haven't heard anything from the app developers yet but I'm hopeful for a response, the form on the mini website was very thorough and I gave as much information as I could.

I do believe I have figured out the problem however, the app wouldn't pair with a spare 5s I have which I had just restored to factory settings and updated to iOS 9.3.1. So I have a 6s and 5s on 9.3.1 that won't pair with connected at all.
I then checked my mums 5s which was still running iOS 9.1, downloaded mini connected on that and it paired straight away with the connected app.
I therefore think I have confirmed that its iOS 9.3.1 that has broken the connection part of the app but apps that were paired already continue to work on 9.3.1.

To fix it you could probably downgrade to previous version of iOS say 9.2 pair the app with the car then update the phone back to 9.3.1. I am unwilling to do this however as it means that I'd be unable to restore my phone from the iCloud backup so I personally wouldn't recommend doing it.

As others are experiencing this problem I would suggest as many people as possible contacting mini regarding the issue in the hope that the app developers will provide an update to fix the issue. Dealers will quite quickly experience issues pairing new customers phones on 9.3.1 to cars so I'm hopeful we should see an update soon.
 

·
Registered
Joined
·
998 Posts
Good job identifying this, its not the first time an ios update has broken an app. I think it was 9.3 that broke the whole BMW Spotify connection interface. Hopefully like you say with new customers this should be picked up quickly
 

·
Registered
Joined
·
2 Posts
Same situation here. I have a 2015 5 door Mini Cooper S with the latest MINI Connected software "UPD07012.Bin". All was working fine and when I upgraded my iPhone 6 software to iOS 9.3.1 I lost the Spotify interface on the car screen and the MINI Connected app does not work with the car. Yes the bluetooth audio streaming still works and the usb audio streaming works, but when I connect Spotify no more cool car interface.

I wrote an email to Mini and this is the latest response I received after I confirmed to them the car has the latest MINI Connect software...

"Your information has been forwarded to our MINI product team. We suggest checking our website periodically for new software releases as it is updated frequently."
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #17 ·
I got an email back from mini as well and after contact the dealer who said it was the latest iOS causing the issue they have just told me to wait for them to update the software with no indication of a time frame which I am less than pleased with.
 

·
Registered
Joined
·
152 Posts
Its strange cause I have a 6s plus on the latest 9.3.2 beta 2 (13F61) release and I plug my phone in via USB and Spotify works fine through the car (via the Spotify interface on the 8.8incher). It also pairs fine via Bluetooth, Siri works fine (I sent a text to the wife on the way home tonight).

Maybe try the 9.3.2 beta?

Also, I don't remember any of the 9.3.1 betas/release giving me grief, though, admitted, I've only had my car a month.
 

·
Registered
Joined
·
2 Posts
Its strange cause I have a 6s plus on the latest 9.3.2 beta 2 (13F61) release and I plug my phone in via USB and Spotify works fine through the car (via the Spotify interface on the 8.8incher). It also pairs fine via Bluetooth, Siri works fine (I sent a text to the wife on the way home tonight).

Maybe try the 9.3.2 beta?

Also, I don't remember any of the 9.3.1 betas/release giving me grief, though, admitted, I've only had my car a month.
What car software version you have on the car? is it the latest on the Mini website?
 

·
Registered
Joined
·
763 Posts
That is pretty strange. I'm on a 6s I updated to iOS 9.3.1 and my MINI Connected is 3.1 and everything works fine.
 
1 - 20 of 30 Posts
Top