Mini Cooper Forum banner
1 - 20 of 30 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
So I ordered the NM Eng Power Module and while installing it I pulled a clip to hard and it shot off.



It's the light grey locking clip.

I've posted on NAM about it, chatted with ecs, placed a phone call with outmotoring (they are trying to find out what it is), and emailed nm eng.

I'm about to drive from NY to Florida on Friday and don't need this getting loose while I'm driving. Plus I'm going to the dealer next Tuesday so don't need them question it.

Thanks for anyone who can help!
 

·
Registered
Joined
·
148 Posts
So I ordered the NM Eng Power Module and while installing it I pulled a clip to hard and it shot off.
Unfortunately, I can't help. I just wanted to offer a THANK YOU (if that's any consolation) for sharing this cautionary tale.

I'm waiting on my NM Engineering Power Module to arrive and will be doing a DIY fitting. Dropping and losing a small (but important) part like that would be the exact thing *I'd* expect to do.

Good luck on the hunt for the replacement. :|

DJ
 

·
Registered
Joined
·
148 Posts
Just a thought.... have you thought about asking the guys at OutMotoring?

They have a pretty big collection of original and OEM spares (including various clips). If they don't have it available they will try to source it - doubly-so if they suspect a forum full of people is hunting for the same part ;-)

DJ
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #7 ·
Just a thought.... have you thought about asking the guys at OutMotoring?

They have a pretty big collection of original and OEM spares (including various clips). If they don't have it available they will try to source it - doubly-so if they suspect a forum full of people is hunting for the same part ;-)

DJ
Yes already spoke to them. They are trying to hunt it down.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #8 ·
I did email NM Eng. They are trying to find it also. They should be getting back to me soon about a replacement part.

As of now I'm going to be using a zip tie to keep it tight.
 

·
Registered
Joined
·
2,082 Posts
Have either one of you been to dealership for any maintenance without the clip being there? And if you did did they say anything?
I was in for an oil change no one boo
Ha! I hear that! One of my biggest fears is taking my MINI to the dealer for anything not absolutely necessary!
 
  • Like
Reactions: pjsjr13

·
Registered
Joined
·
406 Posts
That looks like, according to my research, the T-map sensor. I would have to say you would be hard pressed to find the individual clip for that. There's probably a reason those clips can break off easily (I would guess).

You may have to shell out the $130 ish for the part.

T-Map
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #13 ·
That looks like, according to my research, the T-map sensor. I would have to say you would be hard pressed to find the individual clip for that. There's probably a reason those clips can break off easily (I would guess).

You may have to shell out the $130 ish for the part.

T-Map
I noticed those clips in two other locations. One connected to the engine and the other connected to the Mass Air Connector (to the air intake).
 

·
Registered
Joined
·
406 Posts
What that looks like is possibly just a generic 3 pin adapter. You can buy a repair kit for about $16 and you might be able to cannabalize the clip from that!

Here is the diagram of the part I am referring to. It might be worth you taking a plunge to see if it is what you need. I'm going based solely off the looks in both the part diagram and your first picture.
 
  • Like
Reactions: pjsjr13

·
Registered
Joined
·
266 Posts
I snapped this off too when installing NM module.

Just in case anyone was wondering, the plug works perfectly fine and is still secure (maybe even more secure) without this grey coloured tab part. The only inconvenience is that if you want to disconnect the plug, you need to use a small flat-head screwdriver to lift the tab away from the plug. I had to use a small screwdriver anyway to move the grey tab in the first place so it's a very minor inconvenience in my opinion.
 

·
Registered
Joined
·
148 Posts
I snapped this off too when installing NM module.
As someone who will be installing a NM Power Module later this week (HURRY UP USPS!) this concerns me just a little.

I've already pondered the 'how not to lose it' bit and the things I can do to reduce the risk. As for removing this clip, is there a "safe" method?

Cheers

DJ
 

·
Registered
Joined
·
14 Posts
Just in case anyone was wondering, the plug works perfectly fine and is still secure (maybe even more secure) without this grey coloured tab part.
Completely agree with Jonathan on this. However, if you don't feel comfortable without it, you can probably just zip tie the connectors together.

If you don't want to leave it as is or zip tie it, there is one connector available on ebay. It's from a dismantled vehicle.

http://www.ebay.com/itm/2014-2016-M...Wire-Harness-26-F55-F56-/232014263361?vxp=mtr
 

·
Registered
Joined
·
266 Posts
As someone who will be installing a NM Power Module later this week (HURRY UP USPS!) this concerns me just a little.

I've already pondered the 'how not to lose it' bit and the things I can do to reduce the risk. As for removing this clip, is there a "safe" method?

Cheers

DJ
Practice on the connector to the air flow intake sensor as it's the same type of plug and much easier to access with your hands.

I want to do an install / removal video for the nm power module however it's really quite dark in my garage so I don't know how well it will turn out.
 
1 - 20 of 30 Posts
Top