Mini Cooper Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
our 2015 cooper hatchback has all the lights on the left rear not working: tail, brake and turnsignal. All the other lights work. I finally found a fuse box on the passenger side under the panel, but they all look OK. Anybody have a clue? Where can I get a decent repair manual for this year?
 

·
Registered
Joined
·
2 Posts
My 2015 Mini S has started doing the same thing yesterday. Left for work this morning and it was working again but all my controls for the AC were not where I had them. Did you ever find a solution. Taking it in for a diagnostic next week and it's a whopping $130. Would appreciate any info. Thanks.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
My 2015 Mini S has started doing the same thing yesterday. Left for work this morning and it was working again but all my controls for the AC were not where I had them. Did you ever find a solution. Taking it in for a diagnostic next week and it's a whopping $130. Would appreciate any info. Thanks.
Luckily ours was still just barely under warrantee, so I took it to the dealer and repair was free. There was a burned out circuit board. There are a number of circuit boards relevant to lighting, so unless you have experience, you might need pro help. There is one back with the tail light, and another that I know of inside the right front side wall. You have to pull the carpet on that side.
 

·
Registered
Joined
·
2 Posts
I have an extended warranty but it has stipulations. I'm hoping this will be covered. It does seem like it would be a circuit issue. Thank you so much for your reply, I really appreciate it.
 
1 - 4 of 4 Posts
Top