Mini Cooper Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
152 Posts
Discussion Starter · #1 ·
Had my F56 Cooper S since March but now the cold weather is kicking in i find my Mini is steaming up alot. All through the summer i have had the blowers & circulation on Auto not realy having to adjust antyhing manually. Now that i have to turn the heat up.... when the blowers get warm the windows all steam up!
I have to press the Max Aircon button to demist. I got in the car this morning & inside the car was all misted up inside aswell.
Ive started using the Manual blowers now, i always have to press the button for the direction of air to blow upwards, but every time i get in the car next time it never remember this setting and have to press the button 3 times to make the air blow upwards.
I alsu had the air circulation butoon set to auto through the summer & have now turned it off as that makes the windows steam up.
Any ideas on settings etc for winter driving, should i just keep auto setting swithed off ?
 

·
Registered
Joined
·
64 Posts
Keep it on auto and just press this button until the windows are de-fogged then press it again to go back to normal. This is the window defog button, it blows the air only at the windows, just what you were doing manually.

 

Attachments

·
Registered
Joined
·
998 Posts
Ive noticed some fogging as well recently. Minis have never been that good for air circulation, i was hoping the F56 might have addressed this
 

·
Registered
Joined
·
64 Posts
Ive noticed some fogging as well recently. Minis have never been that good for air circulation, i was hoping the F56 might have addressed this
I agree, mine doesn't do a great job on auto of keeping it from fogging initially, but after pressing that button and clearing it up, the fog never comes back.
 

·
Registered
Joined
·
734 Posts
And if it's too noisy after pressing the button you can just turn the fans down manually... it will still clear the windows just more slowly and quietly.

I've noticed that while that button is lit up auto start stop won't stop the engine.
 

·
Registered
Joined
·
90 Posts
I posted on this before... but you will notice the demister always resets to some weird default every time you stop & start the car. Even if you stop for 30 seconds.

I always press the direction control 3 times when I get start the car. Then, it directs the air to the front window. i.e. single arrow pointing up.

I find, that unless I do this, my lovely Mini will absolutely mist up!! Damned annoying that it won't remember that setting.

The "Max Front Defrost" is all very well - but it's very noisy - you can't leave it on all the time.
 

·
Registered
Joined
·
191 Posts
Having read about other people's issues with fogging up, I was expecting a problem. So far I haven't had any. I've kept everything on auto and used the "max" button that fatherfork pointed out so well. Everything has been crystal clear. I am also very impressed with the windshield wiper blades. They do a lovely job. I opted for the electric defrost in the front window too. It's really quick!
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #12 ·
Just been outside on this cold evening and my mini windows are all steamed up inside again. What causes this ! Its not just steamed up theres water droplets building up on the insude glass.
The car is new and theres nothing damp lying in the boot or anything. Theres cars parked next to me and there screens are crystal clear.
I always keep my windows clean.
I know i can get rid of the steamed up windows by pressing the max button but why does it appear ahhhhhhh! very annoying.
 

·
Registered
Joined
·
64 Posts
Just been outside on this cold evening and my mini windows are all steamed up inside again. What causes this ! Its not just steamed up theres water droplets building up on the insude glass.
The car is new and theres nothing damp lying in the boot or anything. Theres cars parked next to me and there screens are crystal clear.
I always keep my windows clean.
I know i can get rid of the steamed up windows by pressing the max button but why does it appear ahhhhhhh! very annoying.
Sounds like there's moisture in your car somewhere. Not sure why, but you might try something like this video suggests for a few days to see if you can clear it up.

http://youtu.be/4t4mzMS-ZZ8
 
1 - 14 of 14 Posts
Top